Back to overview
Degraded

Asty is down

May 10 at 09:37am UTC
Affected services
EU-01 Server

Resolved
May 10 at 09:39am UTC

Back up! Thanks for your patience!

Created
May 10 at 09:37am UTC

Dashboard currently under degraded performance while is perform an upgrade.